Čer 30 2008

Bude z Debianu odstraněn zavaděč LILO?

Rubrika: Balíčky, Software 13:37  

William Pitcock se ve vývojářském mailing listu zeptal, zda by nebylo moudré odstranit úplně balíček LILO. Balíček nyní vůbec není v testingu, protože obsahuje vážnou chybu, jejíž oprava vyžaduje rozsáhlé změny v kódu. Podle Williama je GRUB už natolik stabilní a bezproblémový, že nemá smysl se o LILO nadále starat. Frans Pop, který je členem týmu starajícího se o instalační části Debianu, s tímto postojem nesouhlasí a podotkl, že stále existuje řada lidí, kteří preferují LILO.


Čer 27 2008

Kam se poděl oficiální VirtualBox repositář pro Debian?

Rubrika: Balíčky 8:54  

Možná jste si všimli, že před časem přestal fungovat repositář, ve kterém InnoTek (nyní součást Sunu) distribuoval balíčky VirtualBox pro Debian a Ubuntu. Repositář byl původně na

deb http://www.virtualbox.org/debian etch non-free

Už nějakou dobu je ale adresář nedostupný a VirtualBox se neaktualizuje. Na oficiální repositář se ptala řada uživatelů, bohužel oficiální odpověď není příliš potěšující: „Bohužel už nebudeme moci poskytovat debianí repositář pro budoucí verze VirtualBoxu, protože teď musíme vyhovět americkým exportním omezením, která vyžadují, aby lidé stahující VirtualBox ‘klikli pro potvrzení’ podmínek.“

Navrhované řešení potvrzovacího dialogu při instalaci balíčku je prý také neakceptovatelné, protože takové potvrzení se objeví až po stažení balíčku. Žádné vhodné technické řešení není ve stávajícím aptu k dispozici, proto nám nezbývá než balíček stahovat ručně.


Čer 26 2008

Budou klíče k Backports.org v repositářích Debianu?

Rubrika: Balíčky, Projekt 9:43  

Robert Millan požádal vývojáře, aby do oficiálních repositářů Debianu Sid přidali sadu klíčů (keyring) pro repositář Backports.org. Svůj požadavek vložil jako bug číslo 480478. Argumentuje tím, že řada uživatelů využívá backporty, které ovšem není možno při instalaci nijak jednoduše ověřit, protože jsou podepsány „neznámými klíči“.

Uživatel si proto z externího repositáře musí nejprve ručně ověřit a nainstalovat balík debian-backports-keyring, což je ovšem značně nepohodlné a pokud by tento balík byl přímo v Debianu, odpadla by řada problémů. Další vývojáři se ale zařazení brání s tím, že se jedná o neoficiální službu, která nemá s Debianem nic společného. Proti nim stojí silná argumentace: balíček jako balíček, software nebo klíče, tento prostě jen přidá pár souborů na disk; navíc Backports využívá mnoho uživatelů Debianu, kterým se tak vyjde vstříc. Debata stále ještě není uzavřená a není tedy jisté, jestli se balík do distribuce dostane.


Čer 26 2008

V Lennym bude kompletní jen němčina a francouzština

Zmražení Debianu Lenny se nám přiblížilo a Christian Perrier proto hodnotí aktuální stav překladů debconf. Z automaticky generovaných statistik vyplývá, že plný překlad bude k dispozici zřejmě jen pro francouzštinu a němčinu. Ačkoliv ještě nejsou překlady úplně dokončeny, chybí už jen několik málo řetězců (24 a 39). Nad 90 % mají ještě portugalština (96 %) a čeština (95 %). Podle Christiana se už ale nestihnou potřebné balíky do repositářů dostat. „Promiňte kluci, zůstanete zřejmě někde u 96 - 99 %. Pokud se nestane nějaký zázrak,“ píše na svém blogu.


Čer 23 2008

Balíček xserver-xorg-video-radeon v unstable

Rubrika: Balíčky, Hardware 12:38  

Možná jste zaznamenali, že se ovladače ATI pro r128 a mach64 oddělily z balíčku ati do samostatných balíků. Kvůli přechodu z Etch na Lenny ale musí server-xorg-video-ati stále záviset na xserver-xorg-video-r128 a xserver-xorg-video-mach64. Pokud se vám tyto balíčky nechce instalovat, můžete využít nový balík xserver-xorg-video-radeon, který se právě objevil v unstable. Obsahuje ovladač pro Radeon a nemá žádné další historické závislosti.


Čer 23 2008

Firefox 3 pro Debian Lenny

Rubrika: Balíčky, Software 12:27  

IceWeasel (tedy Firefox v Debianu) verze 3 je v unstable už několik týdnů. V Lennym stále ještě sedí verze 2.0.0.14. David Moreno vytvořil balíček Iceweasel 3 pro Debian Lenny. Pokud si jej chcete nainstalovat, přidejte si do /etc/apt/sources.list repositář:

deb http://debian.axiombox.com/ testing main


Čer 11 2008

Samba 4 je v repositářích Debian

Rubrika: Balíčky, Software 10:16  

Christian Perrier oznámil, že Samba 4 je nyní součástí Debianu experimental. Stále se jedná o alfaverzi 4.0.0, která je ale schopná na jednom serveru koexistovat se stabilní Sambou 3. Správcem balíků je jeden z vývojářů nové verze Jelmer Vernooij a Samba 4 ještě stále není určená k produkčnímu nasazení.


Čer 10 2008

Jaké je v Debianu počasí?

Rubrika: Balíčky, Vývoj 6:21  

Užitečný balíček edos-debcheck umí prohledat zadaný apt repositář a najít balíčky, které není možné nainstalovat kvůli chybějícím závislostem. Pokud se takové nenainstalovatelné balíky někde nacházejí, jedná se o problém v distribuci, který by měli vývojáři řešit. Ralf Treinen tento balíček používá a denně jím sestavuje seznam problémových balíčků, kterým se pak řídí QA tým Debianu.

Nad tímto balíkem byla také kdysi postavena služba, která ukazuje „počasí v Debianu“. Vyjadřuje problémy s nenainstalovatelnými balíky v meteorologické terminologii: čím méně je problémových balíku, tím je počasí lepší. Tato služba byla bohužel asi před rokem odstavena, ale nyní je počasí v Debianu zpět a máme tak šanci jednoduše sledovat aktuální stav.


Čer 10 2008

Vyšel Debian installer Lenny beta 2

Rubrika: Vývoj 6:09  

Vývojáři oznámili vydání druhé betaverze instalačních médií pro Debian 5.0 Lenny. Počínaje tímto vydáním jsou k dispozici kompletní instalační CD a DVD obrazy. Instalátor nyní používá a také instaluje jádro 2.6.24, přidává podporu pro architekturu armel, verze pro i386 a amd64 má nové boot menu a přibyla podpora pro šifrované diskové oddíly. Pro další informace si prostudujte oficiální oznámení, stahovat můžete na Debian.org.


Čer 09 2008

Bude v Lenny nakonec KDE 3.5.9 nebo KDE 4.1?

Rubrika: Balíčky, Software 9:20  

Zmražení Lennyho se blíží mílovými kroky a vývojáři mají necelý měsíc na provedení posledních „velkých úprav“. Začínají se tedy řešit ty nejdůležitější balíky a tedy i to, co budeme nakonec v Lennym mít. Ana Guerrero z KDE Debian týmu nyní v konferenci otevřela debatu o tom, zda do nového stable padne KDE 4.1 nebo starší verze 3.5.9. Názory jednotlivých vývojářů se rozcházejí. Ana je pro střední cestu: vydat Lenny s KDE 3.5.9, ale přidat vývojářské nástroje z KDE 4: kde4libs, kdepimlibs a kdebase-runtime.

V dlouhém mailu shrnula Ana své důvody:

  • KDE 4.1 nepřináší žádné významné výhody
  • KDE 4.1 zatím ještě nevyšlo
  • bylo by třeba vyřešit mnoho závislostí
  • chybí podpora některých důležitých aplikací
  • třeba kvůli KOffice by bylo třeba držet i starší části KDE
  • také uživatelé jsou spíše proti
  • KDE 4 nefunguje na všech platformách
  • střední cesta uspokojí všechny

Debata mezi vývojáři pokračuje. Co si o tom myslíte vy?


Další stránka »