Čvc 30 2008

SELinux pro Lenny je téměř hotov

Russell Coke oznámil, že SELinux pro Debian Lenny je téměř dokončen. V repositářích je už správná verze knihovny libsepol1 a utilit policycoreutils. Jediné, co zatím chybí, je balík se samotnými politikami selinux-policy-default, který je zatím jen v testingu, protože Russell v něm objevil několik chyb, které musel opravit. Russel je v každém případě se svou prací spokojen. „Přestože je situace poměrně komplikovaná, věřím, že jakmile bude Lenny vydán, budeme pro něj mít nejlepší podporu pro SELinux v historii.“


Čvc 29 2008

Jak kombinovat Debian testing a unstable

Rubrika: Balíčky, Software 9:56  

Po návodu, který říkal jak instalovat balíky z experimental, se mě několik lidí ptalo, zda je možné kombinovat i jiné větve Debianu než jen Sid a experimental. Taková kombinace je realizovatelná a hodí se ve chvíli, kdy chcete mít většinu systému alespoň trochu otestovanou, ale zároveň potřebujete nějaké aktuální balíky z větve druhé. Zde je postup:

Do souboru /etc/apt/apt.conf přidejte řádek informující APT o standardní větvi, které se chcete držet:

APT::Default-Release "testing";

Do /etc/apt/sources.list si pak normálně přidejte zdroje pro větev unstable a updatujte informace o balíčcích. V tuto chvíli se pro vás nic nezměnilo a stále provozujete Debian testing. Pokud potřebujete nějaký balík z unstable, stačí o něj výslovně požádat:

# apt-get -t unstable install balíček1 balíček2 balíček3...

Bez parametru s názvem větve se vám žádný balíček z unstable do systému nedostane. Pokud o něj naopak požádáte, APT inteligentně vyřeší všechny závislosti tak, že stáhne nutné balíky z unstable a zbytek systému nechá být.

Totéž je možno samozřejmě udělat se stable a testingem, ale pravděpodobně to povede velmi brzy k povýšení velkého množství balíčků, protože rozdíl mezi stable a testing je přeci jen propastnější než mezi testing a unstable.


Čvc 28 2008

Lenny byl zmražen

Rubrika: Projekt 10:03  

Marc ‘HE’ Brockschmidt oznámil zmražení Debianu Lenny, které bylo už dříve ohlášeno. Znamená to, že z unstable už nebudou automaticky procházet nové verze, ale jen opravy stávajících balíků. Uživatelé, kteří se podílejí na vývoji, by nyní měli testovat a posílat bugreporty. Některé balíky ale samozřejmě dostanou výjimku a jejich verze se ještě zvýší, protože cílem vývojářů je především přinést co nejkvalitnější distribuci. Stále například v Lennym není jádro 2.6.26, které by se podle správců mělo do finální verze dostat.


Čvc 27 2008

Update Debianu Etch vylepšuje podporu hardware

Rubrika: Projekt 16:23  

Alexander Reichle-Schmehl oznámil vydání čtvrtého update Debianu Etch (aktuální stable), také označované jako Debian 4.0r4. Vydání opravuje několik bezpečnostních chyb, některé technické problémy a jako první nová verze stabilního vydání v historii také vylepšuje podporu hardware. Součástí Etch jsou totiž nyní balíčky z projektu Etch a půl, které nabízejí především nové jádro 2.6.24 (dříve v Etch jen 2.6.18) a také nové balíky X.org. Tyto součásti jsou volitelné a jsou určeny především pro provoz na novějším hardware.


Čvc 25 2008

Jak instalovat balíky z větve experimental

Rubrika: Balíčky 9:05  

Poměrně často se na tomto webu objevují informace o balíčcích ve větvi experimental. Ta je určena skutečně zkušeným uživatelům či vývojářům. Obsahuje naprosto neotestované balíky, které zařazení do běžných repositářů teprve čeká. Proto je doporučuji instalovat jen v případě, že skutečně víte, co děláte. Experimentální větev ale zase na druhou stranu obsahuje velmi čerstvý software, který může někdo potřebovat.

Pokud se rozhodnete nainstalovat nějaké balíky z větve experimental, budete potřebovat Debian testing nebo unstable. Na stable jsou balíčky příliš nové. Do /etc/apt/sources.list si přidejte repositáře Sid, a to i v případě, že používáte testing:

deb http://ftp.cz.debian.org/debian/ sid main non-free contrib
deb-src http://ftp.cz.debian.org/debian/ sid main non-free contrib

Plus ještě přidejte samotné experimentální repositáře:

deb http://ftp.cz.debian.org/debian/ experimental main non-free contrib
deb-src http://ftp.cz.debian.org/debian/ experimental main non-free contrib

A teď to nejdůležitější: APT nenainstaluje balíčky z experimental, pokud jej o to explicitně nepožádáte. Pokud tedy používáte nižší verzí balíčku, který chcete z nového repositáře aktualizovat, neproběhne klasická aktualizace na vyšší verzi z experimentalu. APT se totiž těmto balíčkům vyhýbá. Musíte mu říci, který balík přesně hodláte instalovat:

# aptitude -t experimental install balíček1 balíček2 balíček3

případně

# apt-get -t experimental install balíček1 balíček2 balíček3


Čvc 24 2008

Debian-installer umí nahrát firmware při instalaci

Rubrika: Software 10:30  

Joey Hess oznámil důležitou novinku v instalátoru Debianu: dynamické nahrávání firmware za běhu. Problém totiž je, že některé ovladače zařízení potřebují do hardware před použitím nahrát software, který je ale často binární a nesvobodný. Taková zařízení pak nebudou fungovat, dokud se instalátor nepřipojí k síti a nenastaví si non-free repositáře pro instalaci doplňkových balíků s firmware. To se ovšem nikdy nepodaří, pokud i samotné síťové zařízení vyžaduje inicializaci nesvobodného firmware.

Novinka v instalátoru umožňuje zavedení souborů s firmware přímo z externího média jako je například CD nebo USB disk. Instalátor dokáže automaticky soubory najít a přímo z média použít. Debian-CD tým také připravil archivy z non-free repositářů, které takto můžete jednoduše na přenosné médium nahrát a později při instalaci použít.


Čvc 23 2008

Balíčky pro KDE 4.1 RC1 a KOffice alpha 9

Rubrika: Balíčky, Software 9:30  

Počátkem minulého týdne vyšla první RC verze na KDE 4.1. Ana Guerrero oznámila, že ve větvi experimental jsou již k dispozici příslušné balíčky. Pro instalaci je třeba mít ve zdrojích repositáře větví sid a experimental. Vše je podrobně rozepsáno na stránkách Debian KDE týmu. Zároveň jsou v experimental už balíčky KOffice 2.0 alpha 9.


Čvc 22 2008

Navrhovaná změna značení nových verzí Debianu

Rubrika: Projekt 13:26  

Martin Krafft navrhl změnu verzování nových vydání (stable) Debianu. První číslo by podle něj mělo být zvýšeno vždy s novou verzí a druhé číslo pak s každou důležitou aktualizací, která opravuje chyby. Další verze by pak opět povýšila první číslo. Lenny by podle návrhu byl Debian 5.0, jeho aktualizace 5.1, 5.2 a tak dále. Příští vydání by dostalo verzi 6.0. Speciální vydání, jako třeba Etch a půl by dostala taky vlastní verzi – třeba 5.5.

Lars Wirzenius podotkl, že aktuální verzování bylo vytvořeno kvůli výrobcům médií, kteří se obávali, že by jim po aktualizaci zůstávaly staré instalace ležet ve skladech. Ostatní vývojáři by spíše preferovali „dvoutečkové“ verzování: první číslo by značilo velké vydání, druhé přidávání nových vlastností a třetí by odlišovalo opravy chyb.


Čvc 22 2008

Samba 3.2.0 je v unstable

Rubrika: Balíčky, Software 8:44  

Steve Langasek nahrál do unstable balík Samba 3.2.0. Stalo se tak těsně před zmražením Lennyho. Na novém balíčku se pracovalo několik měsíců, což je také důvod, proč se objevil až teď. Do Lennyho se už ale pravděpodobně nedostane, takže v něm zůstane Samba 3.0.


Čvc 21 2008

Brasero a DVD disky

Rubrika: Balíčky, Software 17:29  

Používáte-li k vypalování GTK program Brasero, možná se vám stalo, že program zahlásil, že na vaše DVD „médium není zapisovatelné pomocí stávající sady zásuvných modulů“. Řešení je poměrně jednoduché: stačí nainstalovat balíček dvd+rw-tools, který právě Brasero využívá při pálení DVD médií.


Další stránka »