Bře 15 2016

APT končí s podporou SHA-1

Julian Andres Klode upozorňuje na to, že vychází nová verze utility APT, která ruší podporu hashovací funkce SHA-1. Objeví se v Debianu unstable a také v připravovaném Ubuntu 16.04 LTS.

Po vydání se může stát, že některé repozitáře třetích stran přestanou správně fungovat než přejdou na silnější SHA-2. Zatím bohužel platí, že GPG podpisy mohou SHA-1 používat, to by se ale také mělo změnit – je v plánu to udělat během prázdnin.

Vložit komentář